Custom Smilies im Test

Heute habe ich seit langem mal wieder eine selber gebastelte Geburtstagskarte veröffentlicht. Dabei fielen mir die vielen kleinen Schönheitsfehler im Kartenblog auf, die ich dann anfing zu beseitigen. Unter anderem habe ich das LMB^Box Smileys Plugin rausgeschmissen und dafür das Custom Smilies Plugin eingebaut. Das ist um Längen besser, schon allein in der Handhabung, nicht so wuchtig wie das andere und mit wenigen Klicks hat man alles fertig eingerichtet.

Smilies im Kartenblog

Wie gewohnt das Plugin downloaden und auf dem Server hochladen. Das Plugin holt die Smilies aus dem WordPress-Smilie-Ordner, also unter /wp-includes/image/smilies, deswegen, falls man andere Smilies möchte, müssen sie in diesem Smilieordner eingefügt werden. Ich habe vorher alle gelöscht und die neuen in den Ordner eingefügt (natürlich meine süssen Blob-Smilies wie ich sie auch hier auf der Blogwiese verwende :love: ). Wichtig, was ich auch nicht gleich wusste, ist es noch die Datei init.php im custom-smilies-Ordner muss auf 777 gestellt werden, erst danach kann man die Smilie-Kürzel unter Verwalten -> Smilies eingeben und abspeichern.

Smilie Kürzel Eingabe im Adminbereich

Das ging alles relativ flott. Und damit die Smilies auch im Kommentarfeld angezeigt werden, muss dieser Code rein:

<?php if ( function_exists(cs_print_smilies) ) {cs_print_smilies();} ?>

Ich werde dann demnächst das Plugin auch hier in der Blogwiese austauschen und einbauen. Das blöde nur dabei, dass dann wieder einige nicht funktionieren in den Beiträgen, da man bei dem LMB^Box Smileys-Plugin einmal mit Zeichen eingeben konnte und einmal mit Text. Es funktionierte jede Eingabe, ob mit oder ohne Bindestrich. Bei dem Custom Smilie kann man nur eine Kombination wählen, entweder Zeichen oder Text je Smilie. Ich denke aber das ich damit leben kann, dafür hat es ja andere Vorteile 😉

Ein Dankeschön auch an Maya für den schnellen Tip via Twitter :*

Update: Austausch ist geglückt. Nachdem ich den Smilies neue Kürzel gegeben habe wollte ich das LMB^Box Smileys deaktivieren, doch das liess das Plugin nicht zu. Also musste ich über ftp die Ordner des alten Plugins löschen und gut war. Habe fertisch :kaffee:

Wenn irgendwelche Probleme auftauchen sollten, dann bitte kurz melden. Wäre sehr dankbar 🙂

52 Gedanken zu “Custom Smilies im Test

  1. Bei mir war(ist) das Problem das ich das alte LMB^Box Smileys-Plugin nicht einfach runter schmeißen konnte – dann funktionierte das Custom Smilies Plugin nicht mehr :hmpf: . Deshalb habe ich es immer noch deaktiviert unter den Plugins stehen :pfeif:

  2. Ich habe auf allen Blogs das LMB^Box-Plugin laufen. Das schöne daran ist, dass man mehrere Smilie-Sets verwalten und parallel nutzen kann, mit getrennter Einrichtung für Posts und Kommentare.

    Aber ich schaue mir das Custom Smilies Plugin mal an, man ist ja lernfähig… 😉

  3. @Nici: Hatte ich auch mal, aber irgendwie hatte ich damit Probleme unter WP 2.5 :hmm:

  4. @Antje: was genau funktioniert dann nicht? Bekommst du Fehlermeldung? Zeigt es die Smilies nicht an?

    @Markus: ja das mit den Sets ist schon praktisch, nur habe ich diese Funktion nie wirklich gebraucht, somit für mich überflüssig 🙂

    @Nici: hatte ich auch schon runtergeladen, doch die Installationsanleitung war mehr als spärlich und da ich im Admin keine Verwaltungs- und Einstellseite fand, ich auch nicht lange suchen wollte, habe ich dann Custom Smilies installiert. Hauptsache es funktioniert 😉

  5. moin

    also wenn du das nerd smilie entsorgt hättescht..drama baby!!
    :nerd:

    vielleicht sollte ich auch mal meine smilies updaten..

  6. oh das Plugin hört sich nicht schlecht an… ich habe ja auch LMB^Smilies… mal schauen, will meiner Tochter ja einen Blog machen.. da werd ich es mal testen! 😎

  7. Schön, wenn ich helfen konnte :*
    Jetzt kann ich bei dir bei wenigstens auch die Smilies anklicken zum einfügen – vorher musste ich mir der Maus drüber, den Code angucken und eintippen :braue:

    BTW: interessantes Blog (Grußkarten) – hab mir den Feed gleich mal gekrallt 🙂

  8. @Nicky: über was mag dein Tochter dann schreiben?

    @Maya: achja, bei dir klappte das anklicken ja nicht. Schön wenns jetzt funzt. Ist ja sonst echt ein Aufwand :nervoes:

    BTW: interessantes Blog (Grußkarten)

    Zur Zeit bastel ich aber nicht mehr soviel da mir die Zeit oft fehlt. Daher ist es ein wenig eingeschlafen. Hoffe aber das es jetzt besser wird 🙂

    @all: wenn es Probleme gibt, dann bitte Bescheid geben. Danke 🙂

  9. Pingback: happy-buddha » Blog Archive » ein herz für grünes !!

  10. Ich hatte das Plugin letztens auch mal aktiviert. Mich hat bloß dabei gestört, dass man immer nur einen Smilie-Text pro Datei angeben kann. Also : – ), oder : )
    (dann ohne Leerzeichen^^)

    Man kann das dann zwar in der init.php dazuschreiben, aber das nächste mal aktualiseren sind dann alle von Hand hinzugefügten Smileys wieder weg… ODer hab ich da was übersehen :hmm:
    Hab’s nämlich jetzt von Hand alles geändert direkt in der functions.php (in wp-includes Verzeichnis)…ohne Plugin… :dead: :ahh:

  11. @Jens: ja das habe ich auch schon bemängelt und deswegen werden in manchen Beiträgen von mir nur noch die alten Kürzel angezeigt statt die Bildchen. Dafür überzeugt es mich aber in der Schlankheit.
    Wenn du die Datei änderst, kannst ja den Absatz abspeichern und nach dem Updaten wieder drüberbügeln. So mach ich es manchmal wenn es wirklich nicht anders geht.

    @Michael: süss ist er ja, aber das grün passt nicht. Die anderen Smilies werden ihn sicher mobben 🙁

  12. Pingback: Neues Smilie-Plugin » Cowboy´s Linux-Blog

  13. @Cindy
    Hab das ganze jetzt elegant gelöst ^^…ich hab einfach die Sachen aus der functions.php (wp-includes), die ich ja schon angepasst hatte, in die init.php kopiert :mrblob:

    Nun funktioniert alles.
    Doch ich musste im Theme in der comment.php die „id“ von von „comments“ auf „comment“ ändern. Darf man das denn einfach so? Bisher läuft auf jeden Fall noch alles 😉

  14. ich bin einfach zu doof für die Smilies *heul* könntest du mir da vielleicht helfen??? Würde mich echt freuen. Ich mag deinen Blog nämlich sehr und denke mir solche Smilies würden meinem Blog auch ein wenig aufpeppen. Meld dich einfach mal wenn du zeit hast bei mir per Mail.
    wäre dir seeeeeeeeeeeeeeeeeeeeeeeeeeehr dankbar

    Liebe Grüße
    Dani

  15. Ja, genau! Das Plugin hab ich ja auch vorgerstern eingebaut – und bin superbegeistert! 🙂

  16. @Jens: Klar, solange alles funktioniert 🙂 Musst halt nur dann beim WordPress-Update aufpassen 😉

    @Dani: Mail ist raus 🙂

    @Chikatze: schön das das Plugin so ankommt :smug:

  17. hihi, ich hatte schon immer customs smilies, es funktioniert schon seit ewigkeiten und hat saemtliche wordpress updates ueberlebt. 🙂
    nur das mit dem code in die comments.php einfuegen, hab ich lange nicht gecheckt. :idee:

  18. Hi, schon so oft war ich bei dir stöbern, gerade kam ich wegen dem Smilie Plugin wieder zu dir. Und vola, nachdem ich hier gelesen habe funkt es auch bei mir. Die liebe Nicky hat mich informiert das meine Smilies gar nicht gezeigt werden im Posting. Nun geht es. Mochte wohl mit dem LMB Box nicht zusammen arbeiten. Also Box runter und Custom Smilie rauf 😉

    Danke an dich hier findet man tolle tips :mrblob:

  19. @Vienn: ich habe am Anfang meiner Bloggerlaufbahn auch immer ewig für den Einbau eines Plugins gebraucht. Mittlerweile weiss man wonach man gucken muss 🙂

    @Isyndra: gern geschehen :kaffee:

  20. Funktioniert denn alles auch ohne die Datei? Wenn nicht, dann sag Bescheid und ich schicke dir diese per Mail.

  21. Nein leider funzt es nicht :,(

    Ich bekomme immer folgende Fehlermeldung:

    init.php is not writeable or nonexistent, so Custom Smilies is not available. If init.php is nonexistent, please create it in /usr/export/www/vhosts/funnetwork/hosting/wayoflife/wp-content/plugins/custom-smilies-se/ and make it writable.

    LG und danke für die Hilfe 🙂
    Way

  22. Vielen Dank für das tolle Plugin.
    LMB^BoxSmileys hat bei mir leider nicht funktioniert. Ging einfach nicht. Komische Sache. ôo
    Das einzige, was ich an Custom Smilie nicht so gut finde, ist, dass man sich für Zeichen oder Text entscheiden muss. Bei einigen hätte ich gern beides, aber naja.
    Vielen Dank auf jeden Fall! Jetzt habe ich endlich smilies drin. 🙂

  23. Also bei mir klappt auch alles.. danke für das tolle Plugin! 🙂 Bin grade erst dabei Blogger zu werden, und da helfen solche „Tutorials“ wie deine enorm. :*

  24. Würde mir jemand anklickbare Smilies in meine Comments.php einbauen, wenn ich ihm diese zusende? Ich bin leider zu doof dafür. 😉

  25. Ich wollte schon immer mal fragen wie du das „more >>“ hinbekommen hast?
    Ist das eine Einstellung oder von dir hinzugefügt?

  26. @Antje: unter Einstellung – Smilie … Dort in dem Feld gibst die Smilies an die zu sehen sein sollen bis das „More“ erscheint. Alle mit Komma getrennt 😉

  27. Hallöchen,
    leider fehlt mir auch diese init.php
    Wie kann ich diese bekommen?

  28. Huhu Cindy,

    danke dir noch für die schnelle Hilfe 🙂 Hat übrigens super funktioniert :*

    Was wäre ich nur ohne deine Freundlichkeit :blush:

  29. ich bekomme meine smilies zwar indie kommentare aber sie sind nicht anklickbar. kannst du mir helfen? :blush:

  30. Puh, da habe ich keine ahnung woran das liegen könnte. Vom Code her stimmt es. Vielleicht funkt da irgendwas anderes dazwischen. Frag mal im WordPressforum nach, die können dir da vielleicht eher helfen. Sorry.

  31. Hallo Cindy, ich bin erst jetzt auf dieses schöne Plugin gestoßen und es funktioniert auch prima. Nur werden mir Adminbereich beim Erstellen eines neuen Artikels oder einer neuen Seite die Smilies nicht angezeigt. Hast du einen Tipp?
    LG Melli

  32. huhuu cindy..

    habs jetzt endlich mal installiert.. geht auch, aber bei mir wird nur der text angezeigt der smilies im kommentarfeld wenn man smilies eingefügt hat, nicht der smilie.. was mach ich nun?

  33. @Melli: also bei mir sind die über dem Kästchen neben „Dateien hinzufügen:“ ganz rechts. Ansonsten weiss ich nicht wie man die sonst einfügt ausser man hat die Kurzformen eh im Kopf 😉

    @Nicky: scheint zu gehen oder?

  34. @ Cindy.. ja lag am LMB Plugin.. als ich es komplett gelöscht habe, denn deaktivieren ging bei mir auch nicht, kamen auch die Smilies.. Und ich musste mir die init.php besorgen, die fehlte bei mir auch..

  35. Danke für den Tipp mit der Eintragung der Zeile „“

    Jetzt werden meinen Lesern auch die Smilies angezeigt. 🙂

  36. Pingback: Plugin-Parade 2010 – meine Lieblingsplugins » Blogwiese

Die Kommentarfunktion ist geschlossen.